Thursday, January 1, 2009

Issue when configuring Workflow Mailer with IMAP and POP enabled in MS-Exchange server 2008

1. While configuring the R12 workflow mailer, the following are the details given,

Inbound(IMAP) - webmail.domain.in 143

Outbound(SMTP) - webmail.domain.in 25

Inbound (POP3) - webmail.domain.in 110

2. The Outbound server has been configured successfully

3. The webmail server's IP has been added in /etc/hosts

4. While trying to configure the Inbound, stuck with the error even the details given are correct

Check the hostname, username and password

Hostname - webmail.domain.in

username - wfmailer

Password – password

5. Then came to know that for inbound they are using both IMAP and POP3

6. Changed the user settings of WFAMILER to use only IMAP

7. Even after that it errors out, but telnet to IMAP and SMTP is successful

$ telnet webmail.domain.in 143

$ telnet webmail.domain.in 25

8. Then with reference to note # 242941.1, tried the following to connect from the user WFMAILER,

$AFJVAPRG -classpath $AF_CLASSPATH -Ddebug=Y -Dprotocol=imap -Ddbcfile=$INST_TOP/appl/fnd/12.0.0/secure/CRP.dbc -Dserver=webmail.domain.in -Dport=143 -Daccount=wfmailer -Dpassword=password -Dconnect_timeout=120 -Dfolder=INBOX oracle.apps.fnd.wf.mailer.Mailer

MLRTST : oracle.apps.fnd.cp.gsc.Logger.Logger(String, int) : Logging to System.out until necessary parameters are retrieved for Logger to be properly started.
DEBUG: setDebug: JavaMail version 1.3.1
DEBUG: getProvider() returning javax.mail.Provider[STORE,imap,com.sun.mail.imap.IMAPStore,Sun Microsystems, Inc]
DEBUG: mail.imap.fetchsize: 16384
* OK The Microsoft Exchange IMAP4 service is ready.
A0 CAPABILITY
* CAPABILITY IMAP4 IMAP4rev1 LOGINDISABLED STARTTLS IDLE NAMESPACE LITERAL+
A0 OK CAPABILITY completed.
A1 LOGIN wfmailer password
A1 BAD Command received in Invalid state.

9. After searching, came to know that the LOGIN is disabled through telnet causing the issue

10. With reference to the note # 333074.1 , with the help of network admin executed the following,

- Checked "SASL Authentication" enabled in EM Websites for the IMAP instance.

- Leave the "Allow Clear Text Login" as is, "True".

- Bounced IMAP

11. Then tried login from telnet and it worked fine,

$AFJVAPRG -classpath $AF_CLASSPATH -Ddebug=Y -Dprotocol=imap -Ddbcfile=$INST_TOP/appl/fnd/12.0.0/secure/CRP.dbc -Dserver=webmail.domain.in -Dport=143 -Daccount=wfmailer -Dpassword=password -Dconnect_timeout=120 -Dfolder=INBOX oracle.apps.fnd.wf.mailer.Mailer

MLRTST : oracle.apps.fnd.cp.gsc.Logger.Logger(String, int) : Logging to System.out until necessary parameters are retrieved for Logger to be properly started.
DEBUG: setDebug: JavaMail version 1.3.1
DEBUG: getProvider() returning javax.mail.Provider[STORE,imap,com.sun.mail.imap.IMAPStore,Sun Microsystems, Inc]
DEBUG: mail.imap.fetchsize: 16384
* OK The Microsoft Exchange IMAP4 service is ready.
A0 CAPABILITY
* CAPABILITY IMAP4 IMAP4rev1 AUTH=NTLM AUTH=GSSAPI AUTH=PLAIN STARTTLS IDLE NAMESPACE LITERAL+
A0 OK CAPABILITY completed.
A1 LOGIN wfmailer password
A1 OK LOGIN completed.
A2 NOOP
A2 OK NOOP completed.

12. Then configured the inbound and its configured successfully without any issues

1 comment:

diana_ser said...

nice tool. However, I have heard about other sql data recovery tools, check it out and find out why it is more efficient